Austin's 1977 Tintop Camper

Kooper271
Posts: 197
Joined: Wed Jun 22, 2016 3:26 pm

Re: Austin's 1977 Tintop Camper

Post by Kooper271 »

Where does this belong? I checked the oil pressure relief valve and everything was happy there...
20170506_124651.jpg
Image
chuckspence
Posts: 289
Joined: Thu Dec 18, 2008 12:42 pm

Re: Austin's 1977 Tintop Camper

Post by chuckspence »

That is your oil filter bypass valve/relief it's part of the spin on oil filter mount (or it used to be) kinda important if you want your oil filtered,it shouldn't have come loose, you may be able to reinstall it and stake it in with a chisel/center punch or you can replace the oil filter mount (you know where to get one if you need another)
Kooper271
Posts: 197
Joined: Wed Jun 22, 2016 3:26 pm

Re: Austin's 1977 Tintop Camper

Post by Kooper271 »

Thanks Chuck. I was able to get it reinstalled
Image
Kooper271
Posts: 197
Joined: Wed Jun 22, 2016 3:26 pm

Re: Austin's 1977 Tintop Camper

Post by Kooper271 »

Tins are all on. Used black rtv to seal some gaps because it fit poorly.

Exhaust is ready to go, just waiting on gaskets (thanks again Bruce).

Sent my fuel injectors and cold start valve to InjectorExperts in Risingsun, Ohio. I couldn't recommend them, their website said 3 day turn around and I've been waiting almost 4 weeks. New excuse every week.

When i get the injectors back i should be good to go.

Threw a really crappy coat of rustoleum primer, then paint and clear coat on my wheels and rear bumper because i was bored one day. Hardly any prep work and no sanding between coats but it looks alright from 30 feet away at 30 miles per hour.

mounted my cheapo tires today. Thunderer ranger r101. Seem to get decent reviews and it was $308 for 5 of them with tax and next day delivery
Attachments
20170601_184550.jpg
20170603_130140.jpg
Image
chuckspence
Posts: 289
Joined: Thu Dec 18, 2008 12:42 pm

Re: Austin's 1977 Tintop Camper

Post by chuckspence »

Ugh... white rims on a bay... really?
John
Posts: 549
Joined: Fri Feb 18, 2011 9:02 pm

Re: Austin's 1977 Tintop Camper

Post by John »

http://www.oreillyauto.com/site/c/detai ... &ppt=C0024

many to chose from, even show cold start valve
Yeah, I never asked for a motorcycle...
Kooper271
Posts: 197
Joined: Wed Jun 22, 2016 3:26 pm

Re: Austin's 1977 Tintop Camper

Post by Kooper271 »

chuckspence wrote: Sat Jun 03, 2017 7:21 pm Ugh... white rims on a bay... really?
They were already painted white. Just really rusty and crappy looking. Eventually I'll have them painted or powdercoated the correct L91 paint but I had the white paint just laying around.

John, thanks for the link. I'll have to look at their cold start valves if my injectors never make it back...
Image
User avatar
Marla
Posts: 1383
Joined: Tue Aug 20, 2013 7:14 am

Re: Austin's 1977 Tintop Camper

Post by Marla »

I think they look great Austin. Nice shiny white paint, how can you go wrong?
It's Marla with an " L"
(My list of assets is just too long...)
User avatar
TRL
Posts: 589
Joined: Tue Jul 03, 2012 1:59 pm

Re: Austin's 1977 Tintop Camper

Post by TRL »

You need to hurry it up! Your missing out on prime bus driving weather :lol: ! But another word of advice, make sure its road ready before you install the motor. Its frustrating to have a great running motor while other bits are broken. Good luck!
The Rick Lang
Kooper271
Posts: 197
Joined: Wed Jun 22, 2016 3:26 pm

Re: Austin's 1977 Tintop Camper

Post by Kooper271 »

Thanks Marla.

Almost there Rick. Got my injectors and CSV installed along with most of the vacuum lines, all of the fuel lines, and my FI harness. There is a chance I could have the engine complete tonight, as long as I figure out a replacement for a couple of vacuum lines I'm missing.

I also learned that you can install an auxiliary air regulator and thermo time switch at the end, with much difficulty.

As far as the bus mechanicals go, i have new rear bearings, brakes, and cv joints. New front brakes as well as (uninstalled) bearings. Gonna leave the front bearings alone if I can. I need to replace my clutch cable, and while the engine is out I want to replace seals and bushings on the transaxle.
Image
Post Reply